• 无法修改数据库配置文件,请手动修改。错误信息:

  • marsaber 于 2021-3-17 20:28:20 156 次浏览 3 参与讨论

操作系统:CentOS Linux release 7.9.2009

Apache版本:httpd-2.4.6-97.el7.centos.x86_64

MySQL版本:mariadb-server-5.5.68-1.el7.x86_64

PHP版本:php-5.4.16-48.el7.x86_64

 

  • 创建表: sc_banner 成功安装 ......
  • 创建表: sc_categories 成功安装 ......
  • 创建表: sc_config 成功安装 ......
  • 创建表: sc_download 成功安装 ......
  • 创建表: sc_email 成功安装 ......
  • 创建表: sc_images 成功安装 ......
  • 创建表: sc_info 成功安装 ......
  • 创建表: sc_lable 成功安装 ......
  • 创建表: sc_language 成功安装 ......
  • 创建表: sc_link 成功安装 ......
  • 创建表: sc_menu 成功安装 ......
  • 创建表: sc_msg 成功安装 ......
  • 创建表: sc_products 成功安装 ......
  • 创建表: sc_tagandseo 成功安装 ......
  • 创建表: sc_user 成功安装 ......
  • 无法修改数据库配置文件,请手动修改。错误信息:
【没有显示错误信息】
难道是因为“本系统需支持 php5.6 + mysql 5.6 + Apache 否则会影响功能使用!”?

======================
2021.3.18早上将PHP和MySQL升级了:
[root@localhost ~]# rpm -qa |grep http
httpd-tools-2.4.6-97.el7.centos.x86_64
httpd-2.4.6-97.el7.centos.x86_64
[root@localhost ~]#
[root@localhost ~]# rpm -qa |grep MariaDB
MariaDB-server-10.0.38-1.el7.centos.x86_64
MariaDB-common-10.0.38-1.el7.centos.x86_64
MariaDB-client-10.0.38-1.el7.centos.x86_64
MariaDB-shared-10.0.38-1.el7.centos.x86_64
[root@localhost ~]#
[root@localhost ~]# rpm -qa |grep php
php56w-cli-5.6.40-1.w7.x86_64
php56w-mysql-5.6.40-1.w7.x86_64
php56w-common-5.6.40-1.w7.x86_64
php56w-pdo-5.6.40-1.w7.x86_64
php56w-gd-5.6.40-1.w7.x86_64
php56w-5.6.40-1.w7.x86_64
[root@localhost ~]#
问题依旧。
============================
出错,有详细的日志文件可以查看吗?

参与讨论 3人

回复
  • 回复 2021-3-18 7:25:46 . marsaber 2楼
  • [root@localhost ~]# rpm -qa |grep http
    httpd-tools-2.4.6-97.el7.centos.x86_64
    httpd-2.4.6-97.el7.centos.x86_64
    [root@localhost ~]#
    [root@localhost ~]# rpm -qa |grep MariaDB
    MariaDB-server-10.0.38-1.el7.centos.x86_64
    MariaDB-common-10.0.38-1.el7.centos.x86_64
    MariaDB-client-10.0.38-1.el7.centos.x86_64
    MariaDB-shared-10.0.38-1.el7.centos.x86_64
    [root@localhost ~]#
    [root@localhost ~]# rpm -qa |grep php
    php56w-cli-5.6.40-1.w7.x86_64
    php56w-mysql-5.6.40-1.w7.x86_64
    php56w-common-5.6.40-1.w7.x86_64
    php56w-pdo-5.6.40-1.w7.x86_64
    php56w-gd-5.6.40-1.w7.x86_64
    php56w-5.6.40-1.w7.x86_64
    [root@localhost ~]#

     

    都升级了,还是不行啊、

  • 回复 2021-3-18 8:36:48 . marsaber 3楼
  • 出错,有日志文件吗?
  • 回复 2021-3-18 10:52:58 . 黑蚂蚁 4楼
  • 数据 库安装成功了,数据库 配置文件没更改过来。估计是 没有写入权限,看这里 http://www.sem-cms.com/talk/?viewid=508
  • 添加一条新的回复

    返回列表
  • 验证码: 验证码
  • HI,欢迎来到SEMCMS外贸网站管理系统
  • 注册 登录
  • SEMCMS公众号扫一扫加关注
    及时了解系统更新情况
  • SEMCMS公众号扫一扫加关注